I'm all tangled up with user permissions

My head is spinning from the user permissions and roles. I was hoping someone could point me in the right direction.

What I’m trying to do seems very easy and works flawlessly when I view as one of my “users.” But for some reason, users aren’t seeing what “view as” shows them seeing.

I want three roles: Admin, Photographer, & User. Simply put I need:

  • Admin and Photographer to see a button in 5 different fields (serving as milestones) that provides them access to an action (button to “Add Photos”)
  • I need the user to not see that button.

I’ve tried conditional permissions, access within each action of each field, permissions, etc. I just can’t find the right combo to make this happen.

Any ideas?

It seems like this process could be simplified greatly within Stacker, especially with the connection to Airtable. When I do research, I seem to be finding only documentation for the old ways.

Any “permission/user” love someone could send me would be much appreciated!

Can you share some screenshots, of your config and what is expected but not working.


@ruchikaabbi Thanks for the help. Here’s a video. To be a bit more clear than I was in the video, I want the role “Photographer” to see the button. I want the standard “user” not to see the button. Thanks!

By any chance is the email of the user being used for another user? I’ve seen similar unexplained errors because of that.

Or custom CSS hiding any buttons?


Thanks for the suggestions, but the email is unique and there is no custom CSS.

Looks Correct in the video. And it is also weird.
a)have you tried to delete this element, and add it again? replicating the procedure?
b) have you tried in for example in Brick or Sheetrock?

Thanks for your suggestions @ruchikaabbi and @ariszagklis . I wanted to update you on Stacker’s support with this. Currently, there is a glitch between Stacker and my “User” tab in Airtable when I choose Automatic. When I manually sort each user, the issue seen above is fixed. This is obviously not a good long-term solution, but the support team assured me they were working on a quick fix. We are also experiencing other user roles change when we update a new one even when they were manually changed. So, it’s all over the place now, but hopefully soon will be fixed.