Admin cannot view Customer only content?


I have 3 group:

  • Admin: access everything
  • Mod: can edit and add some record, but that’s all
  • User (Customer Access): can view what Admin allow them to see.

I have to build a page with 2 section:

  • Section A: public
  • Section B:
    • That customer can view their extra information in this section (I set “Conditional Visibility” with “Email is current User’s email”)
    • Admin and Mod can do anything (create, edit and view)

But in web view mode, Admin and Mod can not view section B, while Customer can view normally.

Of course, Admin can still view Section B while they edit the page layout.

How can I let Admin view Section B in normal view? I tried to add “Conditional Visibility” to “User role is Admin” but the thing is, it’s “AND” condition, so it breaks the rule.

If it’s a “OR” condition, it will be different.

Please advice on this. Thank you!


@phongvt If you’ve set the permissions for User role to see only records that match their email then you don’t need to add the conditional visibility in the field container. Adding it on the field container makes it so for all roles. In which case Admin will not see any records as the email may not match.

Thank you for the answer.
Can I let Admin see the records, eventhough (admin’s) email may not match?

@phongvt Yes. Basically you have to set up permissions as follows;

User role : Can view only records where the email matches current user
Admin : can view all records.

With the above, no conditional visibility needs to be set on the field containers.

I set everything but still not work. Please check the screenshot here: Imgur: The magic of the Internet
Thank you!

@phongvt What’s the expected behaviour? Do you want Admin to see or not see the fields marked red?

Yes I want Admin to see everything. Is it possible?

Yes, you just have to make sure the permissions for that table are set so for Admin to see everything. Now when you add all the fields in the layout, only the Admin will be able to see them.

If the User permission has some fields not set as “Read” then even though they are on the layout, User will not be able to see them.

Hi @phongvt

Ruchika is correct, you need to create permissions in that table to give different access for your user role and your admin role.

Example: For my user role

For my admin role.

These are the two permission rules for that table -

While creating Permission for specific table or the whole base, I can not choose role as Admin. Isn’t it only me?
Please check the screenshot here: Imgur: The magic of the Internet

In your App Settings → Roles, you need to uncheck the “can read/modify all data” for the admin role to be available to add to permissions.

I follow your guidance, create Admin Roles & Permission, but nothing changes. Admin still can not view the “user only” field.

Could you please access my app at @v52 and have a check? I already checked the “Grant Support Login”

Thank you!

Please can you send details of your app and the issue through to

Thank you for the quick and great support. Email sent!

1 Like

hello again, are you Vietnamese? It could be easier if we can directly communite!

Hi @phongvt

I am! but my Vietnamese isn’t very good :cry:

Are you still having problems with your permissions?

I can talk to you in English. I still have the latest issue with permission. It’d be great if we have chance to discuss directly. Please let me how I can reach you!

It is best to email through to