Why are my users seeing 'no records' for one of my tables?

I thought I set everything up right, but my users are seeing this

If one of your tables is showing ‘no records’ here are some things to check:

  1. Check that you have the proper permissions set up

Please check that your permission rules are properly configured and complete (not missing a dropdown selection). If you are user rules, be sure to check the permissions for the role you are impersonating.

  1. Do you have a visibility filter on the table?

In your layout editor for the table, under ‘filter’ check that if you have a filter set. And if so, that the records you’d like to show meet the set conditions.

  1. Less common - If you cannot see the app in admin mode, check if you have set a data filter on the table. (Table > Settings > Data Filter).

  2. Contact support with the name of the table and the user that you are impersonating.